Quantcast

Mount: Structure needs cleaning

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Mount: Structure needs cleaning

tommason
This post has NOT been accepted by the mailing list yet.
Hi,

First up - my knowledge of linux is pretty sparse - I've used it a few times before, so please be gentle!

I've had a neil poulton network space for some time now - it freaked out a while ago and I managed to rig it up to a Ubuntu liveCD via a SATA dock and rescue the files.

This has now happened again - the drive would not get out of a cycle and was not spinning properly. Bring out the dock and liveCD (this time Knoppix). All good. This time however as I eagerly copied files to another drive (a USB powered lacie rugged thing) and left it overnight i woke up to an error. I was copying around 500GB in a few diffferent chunks. The first error it reported was I think error 15? mount structure needs cleaning...

I then tried with a Ubuntu liveCD - same error. This is maybe where I made a bit of an error of my own. In an attempt to shake it out of it's stupor I 'stupidly' plugged it into windows and opened up the disk utility (sorry I'm generally mac based) and deleted in total 5 partitions (3x8mb, 1x250odd mb & 1x600mbish partition) This left the partition that I assumed contained all my files: a 920GB partition. Tried to look at it again on Linux & (both Knoppix & Ubuntu) and the error message had changed slightly. It now reads:
"Error mounting /dev/sdc2 at /media/ubuntu/e8b90eb2-8718-4964-939d-8a2b899b68bd: Command-line `mount -t "xfs" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdc2" "/media/ubuntu/e8b90eb2-8718-4964-939d-8a2b899b68bd"' exited with non-zero exit status 32: mount: Structure needs cleaning"

This drive has all my audio and video stored on it! Any help to move me toward a solution would be much appreciated!

Thanks for your time...

Tom
Loading...